Chronic Logic Forums

Triptych => Triptych Support => Topic started by: abvgdee on May 05, 2015, 06:35:49 PM

Title: re-package the Triptych for 64bit linux
Post by: abvgdee on May 05, 2015, 06:35:49 PM
Hello all!

I apologize for disturbing the 12-year silence here.. :)

May I ask to re-package the Triptych for 64bit linux please? Like 64bit executables in Gish and BCS demos - they run fine. (Triptych looks like an interesting game, strange that I'm first - ever to requests this).

My problem is that (AFAIK) there are no readily-available packages (in the Debian repositories) of 32bit versions of libs: GL, SDL, X11 and Xext (example (https://packages.debian.org/search?searchon=contents&keywords=libGL.so.1&mode=exactfilename&suite=oldstable&arch=amd64)).
Title: Re: re-package the Triptych for 64bit linux
Post by: Chronic Logic - Josiah on May 25, 2015, 01:34:25 PM
Yes please do!
Title: Re: re-package the Triptych for 64bit linux
Post by: abvgdee on June 02, 2015, 04:30:32 AM
Please,
Quote
re-package the Triptych for 64bit linux

I am interested. Thanks.
Title: Re: re-package the Triptych for 64bit linux
Post by: abvgdee on December 07, 2015, 03:06:03 PM
My bad - runs fine (Debian Jessie). i386 libs can be installed after dpkg --add-architecture i386 (https://wiki.debian.org/Multiarch/HOWTO)

(still, native 64bit build would be great)