Author Topic: Multitexture required problem, Win7 32bit  (Read 5288 times)

Locaj

  • Newbie
  • *
  • Posts: 1
    • View Profile
Multitexture required problem, Win7 32bit
« on: November 26, 2010, 01:31:40 PM »
Hi
I got problem with my Gish.

As in title i got this message:
http://img221.imageshack.us/img221/9404/gish.jpg

I have been playing Gish on this system before. I done all modes and now I cant run it. Last time I played was around 2 weeks ago.

I run Windows 7 32bit. ATI x1950 pro card with new drivers (10-2) reinstalled, two times (always uninstall+restar+install).

During this time I was playing around with file I found in Gish Folder oalinst.exe, since OpenAL is for sound i doubt its this. Was turning off and on Windows service called Multimedia Class Scheduler.
Was also changing graphic cards. Tried to install my friends ATI HD 4350 which uses different drivers than mine...

Also Bridge Builder runs very slow. Before the problem Bridge Builder Game was running great, extremely fast. Now its slow as hell.

Please advice...


Many thanks
Regards

/edit: I tried on 1.6v and i tried on demo. Both same screen. Tried do delete \Documents\Gish\config.txt .
« Last Edit: November 26, 2010, 01:35:23 PM by Locaj »

Chronic Logic - Josiah

  • Administrator
  • Hero Member
  • *****
  • Posts: 977
    • View Profile
Re: Multitexture required problem, Win7 32bit
« Reply #1 on: November 27, 2010, 02:52:59 PM »
Hello,

This is definitely a problem with the game not finding your OpenGL drivers.  It sounds like they might have been messed up somehow in the changes.  I would uninstall all your video drivers for your card, download the latest ones from ATI, reset your computer and install the new drivers.  This should fix your problem.


JarrettBillingsley

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Multitexture required problem, Win7 32bit
« Reply #2 on: December 05, 2010, 02:51:22 PM »
I've got the same problem on Win7 64-bit. Thing is, I'm on a laptop that has switchable video cards (one integrated Intel GMA, one discrete GeForce G210M), so updating the drivers is.. daunting at best. I think the only way I can update them is to go through the Asus page, and they really don't seem to keep up with things.

In any case, I haven't had problems with other apps using OpenGL, including those that I've written myself, when it comes to loading the correct OpenGL driver. If I set up a simple SDL context and check the GL version, it reports it as 2.1.

Is there any way to get Gish to dump more detailed info on what's going wrong?

Chronic Logic - Josiah

  • Administrator
  • Hero Member
  • *****
  • Posts: 977
    • View Profile
Re: Multitexture required problem, Win7 32bit
« Reply #3 on: December 06, 2010, 01:22:46 PM »
I know with our OpenGL games they will still run when the OpenGL drivers are not installed correctly, but the framerate will be extremely slow.  Something like this is probably what is happening with your system.  It is finding the Microsoft OpenGL drivers which do not accelerate anything so while it finds the drivers it is not finding the multitexturing.  Make sure you are using the GeForce card and try and install the latest drivers for it from Asus and I think it should work.